Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2000-AVI-051

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 22 septembre 2000
No CERTA-2000-AVI-051

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilités dans CISCOSecure sous Windows NT Server


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2000-AVI-051

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2000-AVI-051
Titre Vulnérabilités dans CISCOSecure sous Windows NT Server
Date de la première version 22 septembre 2000
Date de la dernière version -
Source(s) Cisco Security Advisory
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Contournement des mécanismes d'authentification ;
  • Déni de service ;
  • Exécution de code arbitraire.

2 Systèmes affectés

CiscoSecure Acces Control Server pour Windows NT versions 2.4 (2) et antérieures.

3 Résumé

Plusieurs vulnérabilités ont été découvertes dans le produit CiscoSecure.

Elles permettent à une personne mal intentionnée de :

  • Provoquer une erreur fatale dans le module CSCAdmin ;
  • Placer CiscoSecure ASC dans un état instable ;
  • de contourner les mécanismes d'authentification lorsque CiscoSecure ACS est utilisé avec un serveur LDAP.

4 Description

Le logiciel CiscoSecure ACS est utilisé comme serveur de contrôle d'accès pour définir les accès aux réseaux et les services pouvant être autorisés.

Trois vulnérabilités ont été découvertes :

  • Le module CSAdmin ne vérifie pas correctement certaines variables d'environnement. Un utilisateur mal intentionné peut fabriquer une URL malformée provoquant ainsi un débordement de pile. Ce débordement peut soit provoquer un « plantage » du module CSAdmin ou exécuter du code arbitraire.
  • CiscoSecure ACS utilise TACACS+ afin de gérer l'authentification des utilisateur. Un utilisateur mal intentionné peut, par le biais d'un paquet TACACS+ malformé, mettre le logiciel dans un état instable.
  • Lors de l'utilisation de CiscoSecure ACS avec un annuaire LDAP autorisant l'absence de mot de passe, un utilisateur mal intentionné peut contourner les mécanismes d'authentification afin d'obtenir des privilèges sur un routeur ou un commutateur.

Nota : La version unix n'est pas concernée par ces vulnérabilités

5 Solution

Télécharger la version 2.4 (3) de CiscoSecure ACS :

http://www.cisco.com

6 Documentation

Avis de sécurité Cisco :

http://www.cisco.com/warp/public/707/csecureacsnt-pub.shtml

Gestion détaillée du document

22 septembre 2000
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-06-28