Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2000-AVI-078

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 30 novembre 2000
No CERTA-2000-AVI-078

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans la Machine Virtuelle de Sun : JDK/JRE


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2000-AVI-078

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2000-AVI-078
Titre Vulnérabilité dans la Machine Virtuelle de Sun : JDK/JRE
Date de la première version 30 novembre 2000
Date de la dernière version -
Source(s) Bulletin de sécurité Sun Microsystems
   
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Téléchargement de classe Java non désirée.

2 Systèmes affectés

Toute machine équipée de JDK/JRE (Java Developpement Kit/Java Runtime Environment) sous les versions :

  • Dans la série Windows Production et Solaris Reference Release :
    • JDK/JRE toutes les versions 1.2.2 jusqu'à 1.2.2_004;
    • JDK/JRE toutes les versions 1.2.1 jusqu'à 1.2.1_003;
    • JDK/JRE toutes les versions 1.1.8 jusqu'à 1.1.8_002;
    • JDK/JRE toutes les versions 1.1.7B jusqu'à 1.1.7B_005;
    • JDK/JRE toutes les versions 1.16 jusqu'à 1.16_007.
  • Dans la série Solaris Production Release :
    • toutes les versions JDK/JRE 1.2.2 jusqu'à 1.2.2_05;
    • JDK/JRE 1.2.1;
    • toutes les versions JDK/JRE 1.1.8 jusqu'à 1.1.8_10;
    • JDK/JRE 1.1.7B;
    • JDK/JRE 1.1.6.
  • Dans la série Linux Production Release : toutes les versions 1.2.2 jusqu'à 1.2.2_005 .

3 Description

Java Developement Kit et Java Runtime Environment (JDK/JRE) constituent une machine virtuelle Java développée par Sun. Une vulnérabilité de cette machine virtuelle permet à une classe Java « non fiable » de faire appel à une classe Java interdite.

4 Solution

Installer JDK/JRE 1.3, ou bien, mettre à jour les versions de JDK/JRE :

5 Documentation

L'avis de sécurité de Sun Microsystems :

http://sunsolve.sun.com/pub-cgi/retrieve.pl?doctype=coll&doc=secbull/199&type=0&nav=sec.sba

Gestion détaillée du document

30 novembre 2000
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-20