Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2001-AVI-022

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 27 février 2001
No CERTA-2001-AVI-022

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans le Java Runtime Environment (JRE) de Sun


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2001-AVI-022

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2001-AVI-022
Titre Vulnérabilité dans le Java Runtime Environment (JRE) de Sun
Date de la première version 27 février 2001
Date de la dernière version -
Source(s) Bulletins de sécurité Sun et HP
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de commandes systèmes interdites, élévation de privilèges.

2 Systèmes affectés

Indépendamment du système, les versions suivantes de SDK (Software Development Kit) et JRE sont vulnérables :

  • Sous Windows et Solaris :
    • SDK et JRE 1.2.2_005 et précédentes ;
    • SDK et JRE 1.2.1_003 et précédentes ;
    • JDK et JRE 1.1.8_003 et précédentes ;
    • JDK et JRE 1.1.7B_005 et précédentes ;
    • JDK et JRE 1.1.6_007 et précédentes.
  • Sous Solaris :
    • SDK et JRE 1.2.2_05a et précédentes ;
    • SDK et JRE 1.2.1 ;
    • JDK et JRE 1.1.8_10 et précédentes ;
    • JDK et JRE 1.1.7B ;
    • JDK et JRE 1.1.6.
  • Sous Linux : SDK et JRE 1.2.2_005 et précédentes.
  • Sous HP MPE/iX versions 5.5, 6.0 et 6.5 :
    • JDK/JRE 1.1 ;
    • JDK/JRE 1.2 ;
    • MPE Versions A.22.04 et supérieures.

3 Résumé

Une vulnérabilité du Java Runtime Environment permet à un utilisateur mal intentionné d'exécuter des commandes qui lui sont normalement interdites à l'aide d'une classe Java.

4 Description

Une classe java habilement construite peut faire appel à des commandes non autorisées du système. Cependant, il faut pour cela que la permission ait été donnée à Java d'exécuter au moins une commande.

5 Contournement provisoire

Retirer à Java la permission d'exécuter des commandes en attendant d'appliquer le correctif.

6 Solution

Appliquer le correctif en fonction du produit :

7 Documentation

Bulletin de sécurité Sun :

http://sunsolve.sun.com/pub-cgi/retrieve.pl?doctype=coll&doc=secbull/201&type=0&nav=sec.sba

Bulletin de sécurité HP :

http://itrc.hp.com/

Gestion détaillée du document

27 février 2001
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-07-20