Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2001-AVI-073

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 05 juillet 2001
No CERTA-2001-AVI-073

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité d'Oracle


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2001-AVI-073

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2001-AVI-073
Titre Vulnérabilité d'Oracle
Date de la première version 05 juillet 2001
Date de la dernière version -
Source(s) Avis du CERT/CC CA-2001-16
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Exécution de code arbitraire sur le serveur avec les privilèges du compte utilisé par le processus, permettant aussi la modification de la base de données Oracle.
  • Dans le cas de Windows NT ou 2000, ces privilèges sont ceux de LOCAL_SYSTEM.

2 Systèmes affectés

Oracle 8i.

3 Résumé

Une vulnérabilité de TNS listener permet de compromettre à distance une base de données Oracle sans authentification préalable.

4 Description

TNS (Transparent Network Substate) Listener est un élément de l'interface réseau des base de données Oracle 8i.

Une vulnérabilité de TNS Listener permet à un utilisateur mal intentionné d'obtenir, par le biais d'un débordement de mémoire, les privilèges de l'administrateur de la base de données sans authentification préalable.

5 Solution

Installer la version d'Oracle 9i qui ne présente pas cette vulnérabilité.

Un numéro à été donné à cette vulnérabilité : 1489683 et Oracle met au point un correctif pour les versions 8.1.7, 8.1.6 et 8.0.6 qui sera disponible à l'adresse suivante :

http://metalink.oracle.com

6 Documentation

Gestion détaillée du document

05 juillet 2001
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-08-17