Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2001-AVI-095

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 13 septembre 2001
No CERTA-2001-AVI-095

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité des daemons smap/smapd ( ou CSMAP)


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2001-AVI-095

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2001-AVI-095
Titre Vulnérabilité des daemons smap/smapd ( ou CSMAP)
Date de la première version 13 septembre 2001
Date de la dernière version -
Source(s) Avis CA-2001-25 du CERT/CC
   
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire sur le garde-barrière avec les privilèges du daemon smap/smapd.

2 Systèmes affectés

Tous les systèmes sur lesquels sont installés le daemon smap/smapd (ou CSMAP sur certains systèmes).

Parmis ceux ci :

  • Gauntlet Firewall versions 5.x pour Unix ;
  • PGP e-ppliance série 300 version 1.0, 1.5, 2.0 ;
  • PGP e-ppliance séries 100 et 120 ;
  • PGP e-ppliance série 300 versions 1,5 et 2,0 ;
  • PGP e-ppliance série 1000 versions 1,5 et 2,0 ;
  • MacAfee Webshield pour Solaris 4.1 ;
  • MacAfee e-ppliance séries 100 et 120 ;

D'autres systèmes peuvent être affectés. Contactez votre distributeur.

2.0.0.1

D'après l'éditeur de M-Wall, les versions 4.5 et 4.0 ne sont pas vulnérables.

3 Résumé

Un utilisateur mal intentionné peut exécuter du code arbitraire à distance avec les privilèges des daemons smap/smapd (ou CSMAP).

4 Description

smap/smapd (ou CSMAP) est un service permettant le transfert de courrier à travers des systèmes tels que des garde-barrières.

Grâce à un débordement de mémoire du service smap/smapd (ou CSMAP), un utilisateur mal intentionné peut exécuter du code arbitraire à distance avec les privilèges de ce service.

5 Contournement provisoire

Désactiver ce daemon si vous ne l'utilisez pas.

6 Solution

Appliquer le correctif selon le système :

7 Documentation

Gestion détaillée du document

13 septembre 2001
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23