Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2001-AVI-107

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 7 décembre 2001
No CERTA-2001-AVI-107-01

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans le service RPC ToolTalk


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2001-AVI-107

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2001-AVI-107-01
Titre Vulnérabilité dans le service RPC ToolTalk
Date de la première version 04 octobre 2001
Date de la dernière version 07 décembre 2001
Source(s) Avis de sécurité ISS "Multi-vendor format string vulnerability in ToolTalk"
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service;
  • exécution de code arbitraire à distance avec les privilèges de l'administrateur.

2 Systèmes affectés

  • COMPAQ True 64 DIGITAL UNIX v4.0f, v4.0g, v5.0a, v5.1, v5.1a;
  • HP HP-UX 10.10, 10.20, 10.24, 11.00, 11.04, 11.11;
  • IBM AIX 4.3, 4.3.1, 4.3.2, 4.3.3, 5.1;
  • SGI IRIX 5.2, 5.3, 6.0, 6.1, 6.2, 6.3, 6.4;
  • SUN SOLARIS 8.0 et antérieures.

3 Résumé

Une vulnérabilité dans le service rpc.ttdbserver (ToolTalk) permet à un utilisateur mal intentionné de provoquer un déni de service et dans certains cas d'exécuter du code arbitraire à distance avec élévation de privilèges.

4 Description

ToolTalk est livré avec CDE (Common Desktop Environment) sur la plupart des Unix. Ce service, démarré par défaut, permet à des applications de communiquer à travers le réseau en échangeant des messages.

Une vulnérabilité de type chaîne de format permet à un utilisateur mal intentionné d'exécuter du code arbitraire à distance avec les privilèges de l'utilisateur ayant démarré le service (root).

Une autre exploitation de cette vulnérabilité peut entrainer un déni de service par arrêt du serveur rpc.ttdbserver.

5 Contournement provisoire

Stopper le service rpc.ttdbserver si aucune application ne l'utilise (dans certains cas, celà peut affecter le démarrage du bureau graphique CDE).

6 Solution

Consultez l'éditeur pour l'obtention de correctifs correspondants à votre système.

7 Documentation

Gestion détaillée du document

04 octobre 2001
version initiale.
07 décembre 2001
 
  • mise-à-jour de la section documentation;
  • supression des correctifs temporaires HP et IBM;
  • modification des versions vulnérables de HP-UX.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23