Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2001-AVI-148

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 22 novembre 2001
No CERTA-2001-AVI-148

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans le service d'impression sous HP-UX


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2001-AVI-148

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2001-AVI-148
Titre Vulnérabilité dans le service d'impression sous HP-UX
Date de la première version 22 novembre 2001
Date de la dernière version -
Source(s) Avis CA-2001-32 du CERT/CC
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

Serveurs HP9000 utilisant les versions suivantes:
  • HP-UX version 10.01;
  • HP-UX version 10.10;
  • HP-UX version 10.20;
  • HP-UX version 11.00;
  • HP-UX version 11.11.

3 Résumé

Une vulnérabilité présente dans le service d'impression rlpdaemon de HP-UX permet à un utilisateur mal intentionné d'exécuter du code arbitraire à distance avec les privilèges de root.

4 Description

Le service d'impression rlpdaemon sous HP-UX permet le partage des imprimantes sur un réseau.

L'exploitation d'une vulnérabilité de type débordement de mémoire présente dans ce service permet à un utilisateur mal intentionné d'exécuter du code arbitraire avec les privilèges de root.

Cette vulnérabilité est exploitable à distance.

5 Contournement provisoire

Arrêter le service rlpdaemon en attendant l'application des correctifs.

A défaut, filtrer les accès au port 515/tcp utilisé par ce service afin de limiter l'accès aux seuls clients autorisés.

6 Solution

Un correctif sera publié par Hewlett-Packard avec les références suivantes:
  • HPCO_25107 pour HP-UX version 10.01;
  • HPCO_25108 pour HP-UX version 10.10;
  • HPCO_25109 pour HP-UX version 10.20;
  • HPCO_25110 pour HP-UX version 11.00;
  • HPCO_25111 pour HP-UX version 11.11.

7 Documentation

Gestion détaillée du document

22 novembre 2001
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-08-17