Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2002-AVI-016

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 28 janvier 2002
No CERTA-2002-AVI-016

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité de ptrace dans les systèmes BSD


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2002-AVI-016

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2002-AVI-016
Titre Vulnérabilité de ptrace dans les systèmes BSD
Date de la première version 28 janvier 2002
Date de la dernière version -
Source(s) Avis de sécurité NetBSD 2002-001
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Elévation de privilèges.

2 Systèmes affectés

  • NetBSD 1.5.x versions 1.5.2 et antérieures ;
  • NetBSD 1.4.x versions 1.4.3 et antérieures ;
  • OpenBSD version 3.0 ;
  • FreeBSD versions 4.4 et antérieures.

3 Résumé

Un utilisateur mal intentionné peut, en local, obtenir les droits de l'utilisateur root en utilisant la fonction ptrace.

4 Description

La commande ptrace est une fonction de débuggage qui permet de contrôler l'exécution d'un processus fils, et d'éditer son image mémoire. Il y a des restrictions sur son utilisation avec des processus ayant le drapeau SUID ou SGID activé.

Une vulnérabilité de ces contrôles dans les noyaux BSD permet à un utilisateur mal intentionné d'obtenir les droits de l'utilisateur root.

5 Solution

Appliquer les correctifs des éditeurs (cf. Documentation).

6 Documentation

Gestion détaillée du document

28 janvier 2002
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23