Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2002-AVI-055

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 19 mars 2002
No CERTA-2002-AVI-055

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Contournement de l'autentification pam-pgsql


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2002-AVI-055

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2002-AVI-055
Titre Contournement de l'autentification pam-pgsql
Date de la première version 19 mars 2002
Date de la dernière version -
Source(s) Avis FreeBSD-SA-02:14
  Avis RUS-CERT
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Manipulation d'une base de données contenants des noms et des mots de passe.

2 Systèmes affectés

Toutes les versions de pam-pgsql port sur FreeBSD antérieures à la version 0.5.2 sur FreeBSD.

L'usage de pam-pgsql peut être associé aux outils login et sshd.

3 Résumé

Une vulnérabilité dans un module d'authentification peut contribuer à contourner les mots de passe.

4 Description

PAM (Pluggable Authentification Modules) est un système d'authentification utilisé sur les systèmes Unix. Ce système modulaire permet de développer des applications comme login qui nécessitent une authentification sans avoir à se préoccuper du mécanisme d'authentification qui sera mis en œuvre.

Un des modules d'authentification, pam-pgsql repose sur une base de données PostgresSQL.

Les versions vulnérables de pam-pgsql permettent à un utilisateur local ou distant, pouvant mettre en œuvre l'authentification pam-pgsql, de pouvoir soumettre n'importe quelle requête SQL à la base de données contenant les noms et mots de passe.

Les versions antérieures à 0.3, permettent de surcroît à un utilisateur de contourner le mécanisme de vérification des mots de passe.

5 Contournement provisoire

Désinstaller pam-pgsql si on ne s'en sert pas.

6 Solution

Charger un nouveau squelette du portage de pam-pgsql sur

http://www.freebsd.org/ports
, utilisez pour reconstruire le portage sur FreeBSD.

7 Documentation

Gestion détaillée du document

19 mars 2002
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-28