Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2002-AVI-130

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 11 juillet 2002
No CERTA-2002-AVI-130-003

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité sur Apache


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2002-AVI-130

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2002-AVI-130-003
Titre Vulnérabilité sur Apache
Date de la première version 18 juin 2002
Date de la dernière version 11 juillet 2002
Source(s) Avis CA-2002-17 du Cert-CC
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

  • Apache versions 1.3.x jusqu'à la version 1.3.24 incluse ;
  • Apache versions 2.0.x jusqu'à la version 2.0.36 incluse.

3 Résumé

Une vulnérabilité dans le traitement de certaines requêtes sur Apache permet à un utilisateur mal intentionné d'effectuer un déni de service ou d'exécuter du code arbitraire.

4 Description

Avec le protocole HTTP 1.1, il est possible d'utiliser l'algorithme chunk lorsque la taille des données à envoyer au serveur n'est pas connue à l'avance.

Une vulnérabilité présente dans la routine de traitement des requêtes utilisant cet algorithme peut provoquer l'arrêt du processus fils traitant cette requête.

Dans les versions 2.0.x du serveur Apache, cette vulnérabilité ne peut pas être exploitée pour exécuter du code sur le serveur, mais peut provoquer un déni de service par l'arrêt et le redémarrage de nombreux processus.

Les plates-formes Windows et Netware sont plus sensibles que les autres à ce phénomène.

Dans les versions 1.3.x du serveur, il est en revanche possible de provoquer, par cette vulnérabilité, un débordement de pile et d'exécuter du code arbitraire.

5 Solution

Les versions 1.3.26 et 2.0.39 corrigent la vulnérabilité.

Consulter votre éditeur pour obtenir une mise à jour ou télécharger un correctif sur le site Apache Software Foundation (cf. Documentation).

6 Documentation

Avis CA-2002-17 du Cert-CC :

http://www.cert.org/advisories/CA-2002-17.html

Site Apache Software Foundation :

http://httpd.apache.org

Avis SGI 20020605-01-A :

ftp://patches.sgi.com/support/free/security/advisories/20020605-01-A

Avis Debian DSA-131-2 :

http://www.debian.org/security/2002/dsa-131

Avis SuSE SuSE-SA:2002:022 :

http://www.suse.de/de/support/security/

Avis RedHat RHSA-2002-103 :

http://www.redhat.com/apps/support/errata/

Avis Hewlett Packard HPSBUX0207-197 :

http://www.itresourcecenter.hp.com/

Gestion détaillée du document

18 juin 2002
version initiale.
19 juin 2002
première révision : ajout de précisions sur la vulnérabilité et de l'avis SGI.
20 juin 2002
deuxième révision : ajout des avis RedHat, SuSE et Debian.
11 juillet 2002
troisième révision : ajout de l'avis Hewlett Packard.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-07-21