Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2002-AVI-167

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 05 août 2002
No CERTA-2002-AVI-167

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Problème de gestion des descripteurs de fichier sous BSD


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2002-AVI-167

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2002-AVI-167
Titre Problème de gestion des descripteurs de fichier sous BSD
Date de la première version 05 août 2002
Date de la dernière version -
Source(s) Avis FreeBSD-SA-02:23.stdio
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Elévation de privilèges.

2 Systèmes affectés

  • Toutes les versions de FreeBSD antérieures à la version 4.6-RELEASE (incluse).

    La version 4.6-STABLE (avant la correction du 30 juillet 2002) est également vulnérable.

  • Toutes les versions de OpenBSD antérieures à la version 3.1 (incluse).

3 Résumé

Une mauvaise gestion des descripteurs de fichier sous FreeBSD permet à un utilisateur mal intentionné d'élever ses privilèges.

4 Description

Par convention, sur les systèmes POSIX, les descripteurs de fichier 0, 1 et 2 correspondent respectivement à l'entrée standard, la sortie standard et l'erreur standard.

Les descripteurs de fichier sont alloués séquentiellement, en partant du numéro de descripteur non attribué le plus bas. Si un programme set-uid ou set-gid était lancé avec certains descripteurs d'entrée/sortie fermés (descripteurs 0, 1 et 2), ce programme pourrait ouvrir un fichier et l'associer par erreur à l'entrée standard, la sortie standard ou l'erreur standard. Le programme pourrait ainsi lire des données d'un fichier, ou écrire dans celui-ci par erreur.

L'exploitation de cette vulnérabilité permet, dans certains cas, à un utilisateur local mal intentionné d'obtenir les privilèges root.

5 Solution

Mettre à jour le noyau. Se référer aux avis de sécurité du distributeur.

6 Documentation

Avis de sécurité FreeBSD-SA-02:23.stdio :

ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-02:23.asc

Avis de sécurité OpenBSD fdalloc2 du 8 mai 2002 :

http://www.openbsd.org/errata.html

Gestion détaillée du document

05 août 2002
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-05-24