Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2002-AVI-247

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 15 novembre 2002
No CERTA-2002-AVI-247

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilités de JRun et ColdFusion pour Microsoft IIS


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2002-AVI-247

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2002-AVI-247
Titre Vulnérabilités de JRun et ColdFusion pour Microsoft IIS
Date de la première version 15 novembre 2002
Date de la dernière version -
Source(s) bulletin de sécurité Macromedia
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Elévation de privilèges ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

  • ColdFusion MX (version 6.0 et antérieures) pour IIS 4.0 et 5.0 sous Windows ;
  • JRun 3.0, 3.1 et 4.0 pour IIS sous Windows.

3 Résumé

Il existe une vulnérabilité de type débordement de mémoire exploitable à distance dans les applications ColdFusion et JRun pour IIS sous Windows.

4 Description

ColdFusion et JRun sont des applications crées par Macromedia utilisant la technologie ISAPI (Internet Services Application Programming Interface) et permettant de développer des extensions pour les serveurs web. ISAPI est une technologie permettant aux développeurs de site web de fournir des services plus ou moins élaborées par le biais d'une interface web.

Le filtre ISAPI gérant les noms de fichier possède une vulnérabilité de type débordement de mémoire.

Un utilisateur mal intentionné peut, en utilisant des noms de fichiers très longs, exécuter du code arbitraire sur le serveur IIS avec les privilèges très élevés de l'utilisateur SYSTEM.

5 Solution

Se référer aux bulletins de sécurité Macromedia (voir paragraphe documentation) pour connaître la disponibilité des correctifs.

Nota : Le correctif de JRun est un correctif cumulatif qui corrige d'autres erreurs.

Le Service Pack 1 et le Service Pack 1a pour JRun corrigent les vulnérabilités couvertes par le correctif cumulatif. Ce dernier ne doit donc pas être appliqué si l'un de ces Service Pack a été installé.

6 Documentation

Gestion détaillée du document

15 novembre 2002
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-06-22