Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2002-AVI-275

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 21 janvier 2003
No CERTA-2002-AVI-275-005

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités dans CUPS


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2002-AVI-275

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2002-AVI-275-005
Titre Multiples vulnérabilités dans CUPS
Date de la première version 20 décembre 2002
Date de la dernière version 21 janvier 2003
Source(s) Avis de sécurité de iDEFENSE du 19-12-02
Pièce(s) jointe(s) Aucune
   

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

Toutes les versions de CUPS antérieures à la version 1.1.18.

3 Résumé

De multiples vulnérabilités ont été découvertes dans le système d'impression CUPS (Common Unix Printing System) permettant à un utilisateur mal intentionné de réaliser un déni de service ou d'exécuter du code arbitraire à distance.

4 Description

CUPS est un système d'impression pour Unix développé par Easy Software Products et largement employé dans le monde Unix.
Les systèmes d'exploitations suivants livrent CUPS par défaut :
  • Apple ;
  • GNU/Linux RedHat, Debian, Mandrake, Suse, Slackware ;
  • FreeBSD et NetBSD.
Sept vulnérabilités ont été découvertes dans CUPS permettant à un utilisateur mal intentionné de réaliser un déni de service et d'exécuter du code arbitraire à distance.

5 Contournement provisoire

Filtrer le port 631/TCP au niveau du garde-barrière.

6 Solution

Mettre à jour CUPS en version 1.1.18.
Le téléchargement de la nouvelle version de CUPS se fait depuis l'adresse :
http://www.cups.org/software.html

7 Documentation

Gestion détaillée du document

20 décembre 2002
version initiale.
23 décembre 2002
ajout référence au bulletin de sécurité d'Apple.
03 janvier 2003
ajout des bulletins de sécurité Suse et Gentoo.
13 janvier 2003
ajout du bulletin de sécurité Mandrake.
14 janvier 2003
ajout du bulletin de sécurité RedHat.
21 janvier 2003
ajout du bulletin de sécurité Debian.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-20