Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2003-AVI-067

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 29 avril 2004
No CERTA-2003-AVI-067-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans les émulateurs de terminaux


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2003-AVI-067

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2003-AVI-067-002
Titre Vulnérabilité dans les émulateurs de terminaux
Date de la première version 28 mars 2003
Date de la dernière version 29 avril 2004
Source(s) Bulletin de Digital Defense Incorporated
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Injection de données ;
  • exécution de commandes arbitraires.

2 Systèmes affectés

  • aterm 0.4.x ;
  • Eterm 0.9.x (Eterm 0.9.2 n'est pas vulnérable) ;
  • gnome-terminal 2.x ;
  • hanterm-xf 2.x ;
  • Konsole 3.x ;
  • putty 0.5x ;
  • rxvt 2.7.x ;
  • SecureCRT 3.x ;
  • dtterm.

3 Résumé

Une vulnérabilité a été découverte dans plusieurs émulateurs de terminaux permettant à un individu mal intentionné de détourner des actions effectuées par l'utilisateur du terminal.

4 Description

Une séquence d'échappement est constitué d'une série de caractères débutant par un caractère d'échappement (0x1B) suivi d'une séquence de caractères ordinaires.

Une mauvaise gestion des séquences d'échappement dans plusieurs émulateurs de terminaux permet à un individu mal intentionné de tromper la vigilance d'un utilisateur afin d'exécuter des commandes arbitraires ou de modifier certains fichiers.

5 Solution

Appliquer les correctifs suivants les terminaux utilisés :

Vulnérabilité dans l'émulateur de terminaux rxvt :

Vulnérabilité dans l'émulateur de terminaux gnome-terminal :

Vulnérabilité dans l'émulateur de terminaux Eterm :

Vulnérabilité dans l'émulateur de terminaux dtterm :

  • Bulletin de sécurité HPSBUX0401-309 "SSRT3507 dtterm" de Hewlett-Packard :
    http://itrc.hp.com
    

6 Documentation

Gestion détaillée du document

28 mars 2003
version initiale.
23 janvier 2004
Ajout référence au bulletin de sécurité HPSBUX0401-309 de Hewlett-Packard.
29 avril 2004
Ajout référence au bulletin de sécurité Debian.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-24