Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-007

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 12 mai 2004
No CERTA-2004-AVI-007-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans kdepim


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-007

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-007-002
Titre Vulnérabilité dans kdepim
Date de la première version 15 janvier 2004
Date de la dernière version 12 mai 2004
Source(s) Avis de sécurité KDE 20040114-1
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Elévation de privilèges.

2 Systèmes affectés

Toutes les versions de kdepim incluses dans KDE en version antérieure à la version 3.1.5.

3 Résumé

Une vulnérabilité de kdepim dans la gestion des fichiers VCF permet à un utilisateur d'élever ses privilèges.

4 Description

kdepim (KDE Personal Information Management suite) est un ensemble d'applications permettant la gestion des messages electroniques, des tâches, des rendez-vous et des correspondants. Un débordement de mémoire local dans kdepim permet à un utilisateur mal intentionné, construisant habilement un fichier de type VCF, de réaliser une élévation de privilèges et d'exécuter du code arbitraire sur la machine victime.

5 Solution

Mettre à jour kdepim selon votre distribution (cf. section documentation).

6 Documentation

Gestion détaillée du document

15 janvier 2004
version initiale.
07 avril 2004
ajout du bulletin de sécurité Gentoo.
12 mai 2004
ajout référence au bulletin de sécurité de FreeBSD.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-09-20