Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-016

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 23 janvier 2004
No CERTA-2004-AVI-016

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités sous HP-UX


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-016

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-016
Titre Multiples vulnérabilités sous HP-UX
Date de la première version 23 janvier 2004
Date de la dernière version -
Source(s) Bulletin de sécurité HPSBUX0401-308 de Hewlett-Packard
  Bulletin de sécurité HPSBUX0401-310 de Hewlett-Packard
  Bulletin de sécurité HPSBUX0401-312 de Hewlett-Packard
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Elévation de privilèges ;
  • exécution de code arbitraire à distance ;
  • déni de service.

2 Systèmes affectés

  • HP-UX 11.0, HP-UX 11.04, HP-UX 11.11 (vulnérabilité dans calloc()) ;
  • HP-UX 11.0, HP-UX 11.04, HP-UX 11.11, HP-UX 11.22 (vulnérabilité dans libDtSvc) ;
  • HP-UX 11.0, HP-UX 11.1 (vulnérabilité dans rwrite).

3 Résumé

Hewlett-Packard a publié plusieurs bulletins concernant des vulnérabilités sous HP-UX.

4 Description

Une vulnérabilité est présente dans la fonction calloc(). Un utilisateur mal intentionné peut exploiter cette vulnérabilité au travers d'une application qui utiliserait cette fonction afin d'exécuter du code arbitraire, en local ou à distance, sur une plate-forme vulnérable.


Des vulnérabilités sont également présentes dans la commande /usr/lbin/rwrite ou la bibliothèque libDtSvc. L'exploitation d'une de ces vulnérabilités peut permettre à un utilisateur local de réaliser une élévation de privilèges (obtention des privilèges du super-utlisateur root).

5 Solution

Se référer aux bulletins de sécurité de l'éditeur (cf. section Documentation) pour l'obtention des correctifs.

6 Documentation

  • Bulletin de sécurité HPSBUX0401-308 "SSRT3492 libDtSvc" de Hewlett-Packard :
    http://itrc.hp.com
    
  • Bulletin de sécurité HPSBUX0401-312 "SSRT3556 /usr/lbin/rwrite" de Hewlett-Packard :
    http://itrc.hp.com
    
  • Bulletin de sécurité HPSBUX0401-310 "SSRT2341 calloc(3c) in HP-UX" de Hewlett-Packard :
    http://itrc.hp.com
    

Gestion détaillée du document

23 janvier 2004
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-08-17