Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-030

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 10 février 2004
No CERTA-2004-AVI-030

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilités sur Oracle9i Database


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-030

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-030
Titre Vulnérabilités sur Oracle9i Database
Date de la première version 10 février 2004
Date de la dernière version -
Source(s) Avis de sécurité NGSSoftware
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Elévation de privilèges.

2 Systèmes affectés

  • Oracle9i Database Enterprise Edition v9.2.0.3 ;
  • Oracle9i Database Standard Edition v9.2.0.3.

3 Résumé

Plusieurs vulnérabilités découvertes dans Oracle9i Database permettent à un utilisateur local de réaliser une élévation de privilèges (les privilèges System pour Windows ou Oracle pour Unix).

4 Description

Une faille de type débordement de mémoire présente sur la variable char_expr dans les deux fonctions de conversion NUMTOYMINTERVAL et NUMTODSINTERVAL permet à un utilisateur mal intentionné d'exécuter du code arbitraire sur système.

Deux autres débordements de mémoire sont présents sur les paramètres TZD (Time Zone Difference) de la fonction FROM_TZ et TIME_ZONE.

5 Solution

Mettre à jour Oracle9i Database avec la version Oracle9i Database Release 2, version 9.2.0.3 ou la version 9.2.0.4 en appliquant le patch 3 (cf site Metlalink Oracle, section documentation).

6 Documentation

Gestion détaillée du document

10 février 2004
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-26