Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-034

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 03 juin 2005
No CERTA-2004-AVI-034-007

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités de XFree86 et Xsun


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-034

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-034-007
Titre Multiples vulnérabilités de XFree86 et XSun
Date de la première version 12 février 2004
Date de la dernière version 03 juin 2005
Source(s) Bulletin de sécurité 02.10.04 d'iDEFENSE
  Bulletin de sécurité 200402-02 de Gentoo
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Elévation de privilèges.

2 Systèmes affectés

XFree86 versions 4.3.0 et antérieures.

Xsun et Xprt sous Solaris sont également vulnérables.

3 Description

XFree86 est une mise en oeuvre du système X Window très utilisée sur les plates-formes Linux.

Xsun est le serveur X11 sous Solaris. Xprt est un serveur d'impression sous Solaris.


Deux vulnérabilités de type débordement de mémoire sont présentes dans le code réalisant l'analyse du fichier font.alias.

Par le biais d'un fichier font.alias habilement constitué, un utilisateur mal intentionné peut exploiter une de ces vulnérabilités afin d'obtenir les privilèges du super-utilisateur root sur la plate-forme vulnérable.

4 Solution

Appliquer le correctif disponible sur ftp.xfree86.org :
ftp://ftp.xfree86.org/pub/XFree86/4.3.0/fixes/fontfile.diff
ou réaliser la mise à jour du paquetage XFree86 :

Bulletin de sécurité Sun #57768 du 18 mai 2005 :

http://www.sunsolve.com/search/document.do?assetkey=1-26-57768-1

5 Documentation

Gestion détaillée du document

12 février 2004
version initiale.
13 février 2004
Prise en compte du second bulletin de sécurité d'iDEFENSE. Ajout référence au bulletin de sécurité de Red Hat.
16 février 2004
Ajout référence au bulletin de sécurité de Mandrake.
19 février 2004
Ajout référence aux bulletins de sécurité d'IBM et OpenBSD.
24 février 2004
Ajout référence au bulletin Suse.
29 avril 2004
Ajout référence au bulletin de Hewlett-Packard.
13 mai 2004
Ajout du bulletin de sécurité FreeBSD.
03 juin 2005
Nouveau titre. Ajout référence au bulletin de sécurité de Sun.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-20