Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-076

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 03 septembre 2004
No CERTA-2004-AVI-076-001

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Python 2.2 : Débordement de variable dans la gestion des réponses du DNS


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-076

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-076-001
Titre Python 2.2 : Débordement de variable dans la gestion des réponses du DNS
Date de la première version 10 mars 2004
Date de la dernière version 03 septembre 2004
Source(s) CVE CAN-2004-150
  Avis Mandrake : MDKSA-2004:019
  Debian Security Advisory DSA 458-1
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire.

2 Systèmes affectés

Les versions de 2.2 à 2.2.2 incluse de Python configurées sans la prise en compte du protocole IPv6.

3 Description

Python est un langage de programmation interprété, interactif et orienté objet. Dans l'environnement Unix, il est utilisé pour programmer de nombreuses applications.

Les versions 2.2 à 2.2.2 de Python, lorsqu'elles sont configurées pour ne pas prendre en compte le protocole IPv6, présentent une faille de sécurité dans la fonction getaddrinfo.

Un utilisateur distant mal intentionné peut exploiter cette faille pour confectionner une réponse de DNS malicieuse qui, lorsqu'elle est interprétée par une des versions vulnérables de Python, peut mener à l'exécution de code arbitraire.

Les versions de Python antérieures à 2.2 et à partir de 2.2.3 ne sont pas vulnérables à cette faille de sécurité.

4 Solution

Appliquer le correctif de sécurité. La distribution Debian a fourni un correctif de sécurité : Python 2.2 dans la version 2.2.1-4.3. La distribution Mandrake a fourni un correctif de sécurité : Python 2.2 dans la version 2.2.1-14.4.

Si l'éditeur de votre système d'exploitation n'a pas encore fourni un correctif « clef en main » pour une version vulnérable de Python 2.2, il est possible de compiler une version de Python supérieure ou égale à 2.2.3 à partir des sources.

5 Documentation

Gestion détaillée du document

10 mars 2004
version initiale.
03 septembre 2004
ajout des références aux bulletins de sécurité Gentoo et NetBSD.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-20