Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-244

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 01 mars 2005
No CERTA-2004-AVI-244-007

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité de PHP


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-244

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2004-AVI-244-007
Titre Vulnérabilité de PHP
Date de la première version 15 juillet 2004
Date de la dernière version 01 mars 2005
Source(s) Bulletin de sécurité Mandrake MDKSA-2004:068
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Cross site scripting ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

  • PHP branche 4 : toutes les versions de PHP antérieures à la version 4.3.8 ;
  • PHP branche 5 : toutes les versions de PHP antérieures à la version 5.0.0.

3 Résumé

Deux vulnérabilités dans PHP permettent à un utilisateur mal intentionné de réaliser du cross site scripting ou d'exécuter du code arbitraire à distance sur la plate-forme vulnérable.

4 Description

PHP est un langage de script permettant la réalisation de pages web dynamiques.
Deux vulnérabilités sont présentes dans php :
  • Une première vulnérabilité concerne la directive memory_limit qui peut être déclenchée à un moment voulu. Ceci peut être utilisé par un utilisateur mal intentionné pour exécuter du code arbitraire (CAN-2004-0594) ;
  • Une seconde vulnérabilité concerne la fonction strip_tags(). Cette fonction ne filtre pas correctement certaines balises, ce qui peut conduire un utilisateur mal intentionné à réaliser des attaques de type cross site scripting (CAN-2004-0595).

5 Solution

  • Pour la branche 4 de PHP : mettre à jour PHP en version 4.3.8 ;
  • pour la branche 5 de PHP : mettre à jour PHP en version 5.0.0.

PHP est téléchargeable à l'adresse suivante :

http://www.php.net/downloads.php

Dans tous les cas, se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

15 juillet 2004
version initiale.
16 juillet 2004
ajout de la référence au bulletin de sécurité Gentoo.
16 juillet 2004
ajout de la référence au bulletin de sécurité SUSE.
19 juillet 2004
ajout de la référence au bulletin de sécurité OpenBSD.
20 juillet 2004
ajout des références aux bulletins de sécurité Red Hat.
21 juillet 2004
ajout de la référence au bulletin de sécurité Debian DSA-531.
08 février 2005
ajout de la référence au bulletin de sécurité Debian DSA-669.
01 mars 2005
ajout de la référence au bulletin de sécurité NetBSD.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23