Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-252

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 23 juillet 2004
No CERTA-2004-AVI-252

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité de Courier MTA, Courier-IMAP et Courier SqWebMail


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-252

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2004-AVI-252
Titre Vulnérabilité de Courier MTA, Courier-IMAP et Courier SqWebMail
Date de la première version 23 juillet 2004
Date de la dernière version -
Source(s)  
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Cross-site Scripting ;
  • déni de service ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

  • Courier MTA versions antérieures à la version 0.45 ;
  • Courier-IMAP versions antérieures à la version 3.0.0 ;
  • Courier SqWebMail version 4.0.4 et versions antérieures.

3 Résumé

Plusieurs vulnérabilités dans Courier MTA, Courier-IMAP et Courier SqWebMail permettent à un utilisateur mal intentionné de réaliser de l'injection de données, réaliser un déni de service ou exécuter du code arbitraire à distance.

4 Description

Courier MTA (Mail Transfer Agent) est un serveur de messagerie. Courier-IMAP est un serveur IMAP (Internet Message Access Protocol). Courier SqWebMail est un module de type webmail pour le serveur de messagerie Courier MTA. Plusieurs vulnérabilités ont été identifiées Courier MTA, Courier-IMAP et Courier SqWebMail :
  • Plusieurs débordements de mémoire dans Courier MTA, Courier-IMAP et Courier SqWebMail (CVE CAN-2004-0224) ;
  • une vulnérabilité de type Cross-site Scripting dans la fonction print_header_uc de Courier SqWebMail (CVE CAN-2004-0591) ;
Ces vulnérabilités permettent à un utilisateur mal intentionné de réaliser de l'injection de données, réaliser un déni de service ou exécuter du code arbitraire à distance.

5 Solution

  • Mettre à jour Courier MTA en version 0.45 ou supérieure ;
  • Mettre à jour Courier-IMAP en version 3.0.0 ou supérieure ;
  • Mettre à jour Courier SqWebMail en version 4.0.5 ou supérieure.

6 Documentation

Gestion détaillée du document

23 juillet 2004
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-20