Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-264

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 22 octobre 2004
No CERTA-2004-AVI-264-001

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans la machine virtuelle Java (JRE) de SUN


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-264

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2004-AVI-264-001
Titre Vulnérabilité dans la machine virtuelle Java (JRE) de SUN
Date de la première version 05 août 2004
Date de la dernière version 22 octobre 2004
Source(s) Bulletin de sécurité #57613 de SUN
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Elévation de privilèges ;
  • atteinte à la confidentialité des données.

2 Systèmes affectés

Ces vulnérabilités affectent :

  • SDK et JRE versions 1.4.2_04 et antérieures ;
  • SDK et JRE versions 1.4.1_07 et antérieures ;
  • SDK et JRE versions 1.4.0_04 et antérieures.

sur les plates-formes Windows, Solaris et Linux. Les versions antéreures à 1.4.0 de SDK et JRE ne sont pas affectées par ces vulnérabilités.

3 Résumé

Une vulnérabilité présente dans le processeur XSLT (Extensible Stylesheet Language Transformation) de la machine virtuelle java (JRE) permet à une applet non privilégiée de lire les données d'une autre applet traitée par le processeur XSLT et d'élever ses privilèges.

4 Description

Le JRE (Java Runime Environment) permet l'exécution de code java.

XSLT (Extensible Stylesheet Language Transformation) est un processeur inclu dans le JRE, destiné a réécrire des documents XML (eXtensible Markup Language) vers un format différent.

Une vulnérabilité présente dans le JRE permet à un utilisateur mal intentionné de récuperer des données d'une applet, et d'élever ses privilèges au moyen d'une applet malicieuse contenue dans une page HTML.

5 Solution

Mettre à jour SDK et JRE avec la version 1.4.2_05 ou supérieure :

http://java.sun.com/j2se/

6 Documentation

Gestion détaillée du document

05 août 2004
version initiale.
22 octobre 2004
ajout référence au bulletin de sécurité HPSBUX01087 de HP.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-05-22