Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-278

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 21 septembre 2004
No CERTA-2004-AVI-278-004

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité de la bibliothèque NSS


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-278

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2004-AVI-278-004
Titre Vulnérabilité de la bibliothèque NSS
Date de la première version 26 août 2004
Date de la dernière version 21 septembre 2004
Source(s) Avis de sécurité ISS du 23 août 2004
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire.

2 Systèmes affectés

Tous les produits utilisant la bibliothèque NSS.

3 Résumé

Une vulnérabilité de la bibliothèque NSS permet à un utilisateur distant mal intentionné d'exécuter du code arbitraire sur un système vulnérable.

4 Description

NSS (Network Security Services) est une bibliothèque utilisée pour mettre en oeuvre les communications SSL (Secure Socket Layer).

Elle est principalement utilisée par les serveurs suivants :

  • Netscape Enterprise Server ;
  • Netscape Personalization Engine ;
  • Netscape Directory Server ;
  • Netscape Certificate Management Server ;
  • Sun One/iPlanet ;
  • Sun Java System Web Server.

Une vulnérabilité de type débordement de mémoire a été découverte dans la gestion de la négociation des communications SSlv2 par la bibliothèque NSS.

Cette vulnérabilité permet à un utilisateur mal intentionné d'exécuter du code arbitraire sur le serveur vulnérable. L'attaquant obtiendra les privilèges de l'application utilisant la bibliothèque NSS.

5 Contournement provisoire

Désactiver le support SSLv2.

6 Solution

La version 3.9.2 de NSS corrige cette vulnérabilité. Elle est disponible à l'adresse suivante :
ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_3_9_2_RTM/

7 Documentation

Gestion détaillée du document

26 août 2004
version initiale.
30 août 2004
ajout de la référence au bulletin de sécurité FreeBSD.
01 septembre 2004
ajout de la référence au bulletin de sécurité Sun.
08 septembre 2004
ajout de la référence au bulletin de sécurité HP et ajout de la référence CVE.
21 septembre 2004
ajout de la référence au bulletin de sécurité de SUN du 16 septembre 2004.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-05-22