Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-319

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 24 juin 2005
No CERTA-2004-AVI-319-005

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités dans gdk-pixbuf


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-319

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2004-AVI-319-005
Titre Multiples vulnérabilités dans gdk-pixbuf
Date de la première version 16 septembre 2004
Date de la dernière version 24 juin 2005
Source(s) Bulletin de sécurité Mandrake MDKSA-2004:095
  Bulletin de sécurité Red Hat RHSA:447
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service.
  • Exécution de code arbitraire à distance.

2 Systèmes affectés

gdk-pixbuf 0.22 et versions antérieures.

3 Résumé

De multiples vulnérabilités présentes dans la bibliothèque gdk-pixbuf peuvent être exploitées par un utilisateur mal intentionné afin de réaliser un déni de service ou exécuter du code arbitraire à distance.

4 Description

gdk-pixbuf est une bibliothèque de traitement d'images utilisée dans l'environnement graphique GNOME.


Des vulnérabilités sont présentes dans le traitement d'images de différents formats (BMP, XPM, ICO).

En incitant un utilisateur à visualiser une image habilement constituée, une personne mal intentionnée peut exploiter ces failles afin d'exécuter du code arbitraire à distance sur une plate-forme vulnérable.

5 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

16 septembre 2004
version initiale.
17 septembre 2004
ajout référence au bulletin de sécurité de Debian.
20 septembre 2004
ajout référence au bulletin de sécurité de SuSE. Ajout référence au bulletin de sécurité RHSA-2004:466 de Red Hat et DSA-549 de Debian.
22 septembre 2004
ajout référence au bulletin de sécurité de Gentoo.
28 septembre 2004
ajout référence au bulletin de sécurité de NetBSD.
24 juin 2005
ajout référence au bulletin de sécurité #101776 de Sun.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-07-27