Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-379

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 07 décembre 2004
No CERTA-2004-AVI-379-004

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités dans Cyrus Imap Serveur


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-379

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2004-AVI-379-004
Titre Multiples vulnérabilités dans Cyrus Imap Serveur
Date de la première version 23 novembre 2004
Date de la dernière version 07 décembre 2004
Source(s) Avis de sécurité e-matters
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

Cyrus Imap Server version 2.x. Pour le détail des versions affectées par les différentes vulnérabilités voir la section Description.

3 Résumé

Plusieurs vulnérabilités présentes dans Cyrus Imap Serveur permettent à un utilisateur mal intentionné de réaliser un déni de service ou d'exécuter du code arbitraire à distance.

4 Description

Cyrus Imap Server est un serveur IMAP (Internet Message Access Protocol). Quatres vulnérabilités sont présentes sur ce serveur :
  • Une vulnérabilité dans le traitement des commandes PROXY et LOGIN permet à un utilisateur mal intentionné, via l'utilisation d'un nom d'utilisateur malicieusement construit, de réaliser un déni de service ou d'exécuter du code arbitraire sur le système où se trouve le serveur vulnérable. Les versions 2.2.4 à 2.2.8 sont affectées par cette vulnérabilité.
  • Une vulnérabilité dans le traitement d'un argument de la commande PARTIAL permet à un utilisateur mal intentionné de référencer une adresse mémoire externe au tampon. Les versions 2.2.6 et antérieures sont affectées par cette vulnérabilité.
  • Une vulnérabilité dans le traitement d'un argument de la commande FETCH permet à un utilisateur mal intentionné de référencer une adresse mémoire externe au tampon. Les versions 2.2.8 et antérieures sont affectées par cette vulnérabilité.
  • Une vulnérabilité dans la commande APPEND dûe à une erreur de programmation permet à un utilisateur mal intentionné de réaliser un déni de service ou d'exécuter du code arbitraire à distance. Les versions 2.2.7 et 2.2.8 sont affectées par cette vulnérabilité.

5 Solution

Mettre à jour le serveur avec la version 2.2.9 ou une version postérieure.

6 Documentation

Gestion détaillée du document

23 novembre 2004
version initiale.
25 novembre 2004
ajout de la référence au bulletin de sécurité Debian et aux références CVE.
25 novembre 2004
ajout de la référence au bulletin de sécurité Gentoo.
26 novembre 2004
ajout de la référence au bulletin de sécurité Mandrake.
07 décembre 2004
ajout de la référence au bulletin de sécurité SuSE.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-06-22