Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2005-AVI-004

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 25 janvier 2005
No CERTA-2005-AVI-004-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans Xine


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2005-AVI-004

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2005-AVI-004-002
Titre Vulnérabilité dans Xine
Date de la première version 04 janvier 2005
Date de la dernière version 25 janvier 2005
Source(s) Bulletin de sécurité XSA-2004-7 de Xine
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

  • Toutes les versions 1-alpha ;
  • toutes les versions 1-beta ;
  • toutes les versions 1-rc.

Les versions antérieures à la versions 1-alpha0 ainsi que les version 1.0 et ultérieures sont non affectées.

3 Résumé

Une vulnérabilité dans le démultiplexeur AIFF de Xine permet l'exécution de code arbitraire à distance.

4 Description

AIFF (Audio Interchange File Format) est un format de fichier reconnu par la bibliothèque xine-lib.

Une vulnérabilité est présente dans la routine de traitement des en-têtes de fichiers au format AIFF dans xine. Un utilisateur mal intentionné peut provoquer l'exécution de code arbitraire à distance, par le biais d'un fichier ou d'un site web habilement constitués.

L'exploitation de cette vulnérabilité ne se limite pas aux fichiers AIFF, car le démultiplexeur AIFF peut être utilisé pour traiter des fichiers qui ne sont pas au format AIFF.

5 Solution

Se référer au site de Xine pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

04 janvier 2005
version initiale.
07 janvier 2005
ajout référence au bulletin de sécurité Gentoo GLSA-200501-07.
25 janvier 2005
ajout référence au bulletin de sécurité Mandrake MDKSA-2005:011.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-30