Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2005-AVI-346

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 05 octobre 2005
No CERTA-2005-AVI-346-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité des clients web Mozilla, Firefox, Netscape et du client mail Thunderbird


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2005-AVI-346

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2005-AVI-346-002
Titre Vulnérabilité des clients web Mozilla, Firefox, Thunderbird et Netscape
Date de la première version 15 septembre 2005
Date de la dernière version 05 octobre 2005
Source(s) Avis Security-Protocols du 08 septembre 2005
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service ;
  • exécution potentielle de code arbitraire à distance.

2 Systèmes affectés

Tout système - quel que soit le système d'exploitation - utilisant un butineur Mozilla, Mozilla-Firefox ou Netscape.

La vulnérabilité existe mais ne peut être exploitée par défaut sur le client de messagerie Mozilla Thunderbird.

3 Résumé

Il est possible de créer une page web contenant un lien volontairement mal formé qui va bloquer le butineur. L'exécution de code avec les privilèges de l'utilisateur courant n'est pas exclue.

4 Description

Une erreur dans la prise en compte des noms de domaines internationaux (« IDN », extension des noms de domaine à des caractères non ASCII) peut provoquer un débordement de tampon en mémoire.

5 Contournement provisoire

Désactiver le support d'IDN dans le butineur (voir le vendeur Mozilla dans la section Documentation) en exécutant le correctif proposé ou en éditant la configuration à l'aide de la commande about:config dans la barre de navigation et en positionnant la valeur network.enableIDN à false.

6 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

7 Documentation

Gestion détaillée du document

15 septembre 2005
version initiale.
03 octobre 2005
ajout de la référence au bulletin de sécurité Debian.
04 octobre 2005
ajout de Mozilla Thunderbird dans la section ``Systèmes affectés''.
05 octobre 2005
ajout de la référence au bulletin HP-UX.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-05-24