Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2005-AVI-400

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 04 janvier 2006
No CERTA-2005-AVI-400-004

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Faiblesse dans OpenSSL 0.9.x


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2005-AVI-400

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2005-AVI-400-004
Titre Faiblesse dans OpenSSL 0.9.x
Date de la première version 12 octobre 2005
Date de la dernière version 04 janvier 2006
Source(s) Avis OpenSSL du 11 octobre 2005
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Contournement de la politique de sécurité,
  • risque d'atteinte à la confidentialité des échanges.

2 Systèmes affectés

Tout système utilisant OpenSSL en versions sources 0.9.7 jusqu'à 0.9.7g ou 0.9.8 et les betas antérieures.

Par extension, sont concernés tous les serveurs utilisant OpenSSL pour le support de SSL/TLS. En particulier les versions SSL du serveur web Apache, des serveurs de courrier qmail, postfix, Exim, du serveur d'annuaire OpenLDAP,...peuvent être impactés.

3 Résumé

Un utilisateur mal intentionné, ayant la capacité d'intercepter le flux TCP, peut conduire une attaque par le milieu visant à faire régresser à la version 2 le protocole SSL négocié entre les parties.

4 Description

OpenSSL est une mise en oeuvre « open source » des protocoles Secure Sockets Layer (SSL) et Transport Layer Security (TLS). OpenSSL est largement utilisé comme bibliothèque pour sécuriser des protocoles applicatifs sur l'Internet.

Les versions du protocole SSL usuellement supportée sont v2 et v3, sachant que l'on peut assimiler TLS à une version v3.1. Cependant le support de v2 n'est conservé que pour des raisons de compatibilité ascendante et n'est plus vraiment justifié de nos jours la v3 datant de novembre 1996. L'usage de SSLv2 est fortement déconseillé étant donné des faiblesses cryptographiques majeures qui ont conduit à l'élaboration de la version v3.

L'usage d'un code, développé pour assurer la compatibilité avec des produits tiers, supprime la vérification d'une éventuelle attaque en régression sur la version négociée, lors de l'établissement d'une session SSLv2.

Il est ainsi possible, pour un utilisateur en position d'interception, de forcer l'utilisation de SSLv2 entre 2 parties alors que SSLv3 ou TLS étaient possibles. Celui-ci pourra alors tenter d'exploiter les faiblesses de SSLv2 pour attenter à la confidentialité de l'échange.

5 Contournement provisoire

Désactiver le support de SSLv2 dans toute application utilisant OpenSSL.

6 Solution

Mettre à jour les sources en versions 0.9.7h ou 0.9.8a au moins, ou se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

7 Documentation

Gestion détaillée du document

12 octobre 2005
version initiale ;
07 novembre 2005
ajouts des bulletins Fedora Core 3 et 4, du bulletin SuSE et de 3 avis Debian ;
08 novembre 2005
ajout des références aux bulletins de sécurité Debian DSA-888 et Ubuntu ;
05 décembre 2005
ajout de la référence à l'avis de sécurité Cisco.
04 janvier 2006
ajout de la référence à l'avis de sécurité Juniper.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-07-21