Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2005-AVI-499

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 17 mars 2006
No CERTA-2005-AVI-499-004

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans la bibliothèque libavcodec de FFmpeg


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2005-AVI-499

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2005-AVI-499-004
Titre Vulnérabilité dans la bibliothèque libavcodec
Date de la première version 22 décembre 2005
Date de la dernière version 17 mars 2006
Source(s) Liste de diffusion BugTraq
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service ;
  • exécution de code arbitraire à distance.

2 Systèmes affectés

  • FFmpeg versions 0.x ;
  • Xline-lib 1.x.

3 Résumé

Une vulnérabilité présente dans la bibliothèque libavcodec de FFmpeg peut être exploitée par un utilisateur mal intentionné pour réaliser un déni de service ou exécuter du code arbitraire à distance.

4 Description

La bibliothèque libavcodec est le composant chargé de la compression et de la décompression dans divers formats (mpeg, png...).

Une vulnérabilité présente dans la fonction avcodec_default_get_buffer du programme utils.c de cette bibliothèque peut être exploitée par un utilisateur mal intentionné pour réaliser un deni de service ou pour exécuter du code arbitraire à distance à partir d'un fichier au format png malicieusement construit.

5 Solution

Appliquer les correctifs disponibles sur le site de votre éditeur.

6 Documentation

7 Documentation

Gestion détaillée du document

22 décembre 2005
version initiale.
16 janvier 2006
ajout des références aux bulletins de sécurité Mandriva et Gentoo 200601-06.
08 mars 2006
ajout de la référence aux bulletin de sécurité Gentoo 200603-03.
10 mars 2006
ajout de la référence au bulletin de sécurité Debian DSA-992.
17 mars 2006
ajout des références aux bulletins de sécurité Gentoo 200602-01, Debian DSA-1004 et DSA-1005.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-07-27