Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2006-AVI-526

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 26 mars 2007
No CERTA-2006-AVI-526-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilités dans SquirrelMail


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2006-AVI-526

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2006-AVI-526-002
Titre Vulnérabilités dans SquirrelMail
Date de la première version 04 décembre 2006
Date de la dernière version 26 mars 2007
Source(s) Bulletin de sécurité SquirrelMail du 02 décembre 2006
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Attaque de type Cross Site Scripting.

2 Systèmes affectés

Toute version de SquirrelMail antérieures à 1.4.9a.

3 Résumé

Deux vulnérabilités dans SquirrelMail permettent à un utilisateur distant de réaliser une attaque de type Cross Site Scripting.

4 Description

Ces vulnérabilités sont causées par un manque de contrôle sur les arguments retournés à l'utilisateur et par une erreur dans le filtre HTML magicHTML. Les scripts PHP vulnérables, webmail.php et compose.php, sont exécutés depuis les menus draft, compose et mailto. Un utilisateur distant peut exploiter ces vulnérabilités afin d'injecter du code arbitraire depuis le serveur (sain) et l'exécuter dans le contexte du navigateur Internet de l'utilisateur connecté.

5 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

04 décembre 2006
version initiale.
02 février 2007
ajout des références aux bullentins de sécurité RedHat, Debian et SuSE.
26 mars 2007
ajout de la référence au bulletin de sécurité SuSE.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-07-21