Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2007-ALE-005

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 28 février 2007
No CERTA-2007-ALE-005-002

Affaire suivie par :

CERTA

BULLETIN D'ALERTE DU CERTA

Objet : Vulnérabilité de Sun Solaris


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2007-ALE-005

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2007-ALE-005-002
Titre Vulnérabilité de Sun Solaris
Date de la première version 12 février 2007
Date de la dernière version 18 septembre 2008
Source(s)  
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Contournement de la politique de sécurité.

2 Systèmes affectés

  • Sun Solaris 10 ;
  • Sun Solaris Express.

3 Résumé

Une vulnérabilité permettant une connexion non légitime à distance a été découverte dans le système d'exploitation Sun Solaris.

4 Description

Une vulnérabilité a été découverte dans la conjonction du service telnetd et de la commande /usr/cmd/login. Cette vulnérabilité peut être exploitée par une personne distante afin de se connecter à la machine vulnérable sous un nom d'utilisateur légitime, à condition d'en connaître un. Le système n'est cependant vulnérable qu'à la condition où le service telnetd soit démarré avec les droits root.

L'exploitation de cette vulnérabilité est triviale et un code d'exploitation circule sur l'Internet. D'autres services de connexion à distance présentent potentiellement le même type de vulnérabilité.

28 février 2007 : le CERTA a été informé de la propagation d'un ver exploitant cette vulnérabilité. Des méthodes pour le détecter sont fournies par Sun à l'adresse ci-dessous :

http://blogs.sun.com/security/entry/solaris_in_telnetd_worm_seen

5 Contournement provisoire

Désactiver le service telnetd grâce à la commande suivante :
svcadm disable telnetd

Par précaution, désactiver de la même manière les services rlogind, klogin, eklogin :

svcadm disable rlogind
svcadm disable klogin
svcadm disable eklogin

Il est également recommandé de vérifier que l'accès au port TCP 23 est correctement filtré au niveau des pare-feux, en accord avec la politique de sécurité.

6 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

7 Documentation

Gestion détaillée du document

12 février 2007
version initiale.
28 février 2007
ajout d'informations concernant la propagation d'un ver et solution.
18 septembre 2008
passage en statut corrigé, ajout de la référence CVE.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23