Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2007-AVI-377

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 07 décembre 2009
No CERTA-2007-AVI-377-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans GNU tar


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2007-AVI-377

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2007-AVI-377-002
Titre Vulnérabilité dans GNU tar
Date de la première version 24 août 2007
Date de la dernière version 07 décembre 2009
Source(s) Bulletin de sécurité Redhat RHSA-2007:0860 du 23 août 2007
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Contournement de la politique de sécurité.

2 Systèmes affectés

  • GNU tar versions antérieures à 1.18 ;
  • Solaris 9 sur SPARC ;
  • Solaris 10 sur SPARC sans le patch 139099-03 ;
  • OpenSolaris sur SPARC de svn_01 à svn _115 ;
  • Solaris 9 sur x86 ;
  • Solaris 10 sur x86 sans le patch 139100-03 ;
  • OpenSolaris sur x86 de svn_01 à svn_11.

3 Résumé

Une vulnérabilité de GNU tar permet de contourner la politique de sécurité.

4 Description

Un manque de vérification de certains attributs d'une archive tar permet à un utilisateur malveillant d'extraire des fichiers ou des dossiers contenus dans l'archive vers des emplacements arbitraires. Un utilisateur exploitant cette vulnérabilité peut contourner la politique de sécurité en créant ou en écrasant des données sensibles.

5 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

24 août 2007
version initiale.
07 octobre 2008
ajout des références aux bulletins de sécurité Gentoo, Debian, Mandriva, SuSE, Ubuntu, FreeBSD et Avaya.
07 décembre 2009
ajout des références au bulletin de sécurité Sun 1-66-273551-1 du 02 décembre 2009.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-28