Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2008-AVI-020

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 15 janvier 2008
No CERTA-2008-AVI-020

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités de FreeBSD


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2008-AVI-020

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2008-AVI-020
Titre Multiples vulnérabilités de FreeBSD
Date de la première version 15 janvier 2008
Date de la dernière version -
Source(s) Bulletins de sécurité FreeBSD du 14 janvier 2008
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Exécution de code arbitraire à distance ;
  • déni de service à distance ;
  • atteinte à la confidentialité des données.

2 Systèmes affectés

FreeBSD 6.x.

3 Résumé

De multiples vulnérabilités affectent FreeBSD. Ces vulnérabilités peuvent être exploitées afin d'exécuter des commandes arbitraires à distance ou accéder à des informations sensibles en local.

4 Description

Trois vulnérabilités ont été découvertes dans FreeBSD :

  • la première résulte d'une erreur de gestion de limite de boucle (off-by-one) au niveau de la fonction inet_network(). Cette vulnérabilité peut être exploitée à distance par un utilisateur malintentionné afin d'exécuter du code ;
  • la seconde est due à une erreur dans la fonction openpty(). Cette vulnérabilité peut être exploitée en local afin d'accéder à des informations confidentielles pour un utilisateur standard ;
  • enfin, la dernière vulnérabilité est due à une erreur dans le fonction ptsname(). Cette vulnérabilité peut être exploitée en local afin de devenir propriétaire d'un pty à accès restreint.

5 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

15 janvier 2008
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-05-23