Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2008-AVI-099

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 21 février 2008
No CERTA-2008-AVI-099

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilités de BEA Weblogic


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2008-AVI-099

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2008-AVI-099
Titre Vulnérabilités de BEA Weblogic
Date de la première version 21 février 2008
Date de la dernière version -
Source(s) Bulletins de sécurité BEA 256 à 275
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Exécution de code arbitraire à distance ;
  • atteinte à l'intégrité des données ;
  • atteinte à la confidentialité des données.

2 Systèmes affectés

  • BEA Weblogic Express, versions 6.x à 10.x ;
  • BEA Weblogic Portal, versions 8.x à 10.x ;
  • BEA Weblogic Server, versions 6.x à 10.x ;
  • BEA Weblogic Workshop, versions 8 ;
  • BEA Workshop for Weblogic , versions 9.x et 10.x.

3 Résumé

De nombreuses vulnérabilités affectent les produits BEA Weblogic. Leur exploitation permet à un utilisateur malveillant d'exécuter du code arbitraire à distance ou de porter atteinte à l'intégrité ou à la confidentialité des données.

4 Description

De nombreuses vulnérabilités affectent les produits BEA Weblogic :
  • une erreur de traitement des requêtes par HttpProxyServlet et HttpClusterServlet permet à un utilisateur d'obtenir des droits d'administration sur le serveur, dans certaines conditions ;
  • des erreurs non précisées permettent de réaliser de l'injection de code indirecte (cross site scripting) sur le poste de l'utilisateur ;
  • une erreur dans la console d'administration permet de réaliser de l'injection de code indirecte (cross site scripting) sur le poste d'un administrateur ;
  • des erreurs non précisées permettent de contourner la politique de sécurité, en particulier d'accéder à des servlettes non autorisées ;
  • un problème de gestion des sessions permet de détourner la session d'un utilisateur ;
  • une erreur dans la gestion des sessions HTTPS peut conduire à une redirection en HTTP ;
  • un défaut de verrouillage des comptes permet à un utilisateur malveillant de procéder à une recherche exhaustive de mots de passe ;
  • la protection des mots de passe de bases de données est insuffisante. L'exploitation de cette faiblesse n'est possible que si RDBMS Authentification est utilisé.

5 Solution

Se référer aux bulletins de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

21 février 2008
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-05-29