Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2009-ALE-006

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 13 mai 2009
No CERTA-2009-ALE-006-003

Affaire suivie par :

CERTA

BULLETIN D'ALERTE DU CERTA

Objet : Multiples vulnérabilités dans Adobe Reader et Adobe Acrobat


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2009-ALE-006

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2009-ALE-006-003
Titre Multiples vulnérabilités dans Adobe Reader et Adobe Acrobat
Date de la première version 28 avril 2009
Date de la dernière version 13 mai 2009
Source(s)  
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

  • Adobe Acrobat et Adobe Reader versions 7.1.1 et antérieures ;
  • Adobe Acrobat et Adobe Reader versions 8.1.4 et antérieures ;
  • Adobe Acrobat et Adobe Reader versions 9.1 et antérieures.

3 Résumé

Deux vulnérabilités présentes dans Adobe Reader et Adobe Acrobat permettent à un utilisateur distant d'exécuter du code arbitraire.

4 Description

Deux vulnérabilités sont présentes dans Adobe Reader et Adobe Acrobat. Elles sont relatives à certaines fonctions mises en œuvre dans le contexte du moteur de rendu JavaScript de Adobe Reader et Adobe Acrobat. Ces failles permettent toutes les deux à un utilisateur malintentionné distant d'exécuter du code arbitraire par le biais d'un pointeur vers un fichier PDF construit de façon particulière.

Ces vulnérabilités s'appuyant uniquement sur des fonctions Javascript, elles ne sont donc pas dépendantes d'une plateforme particulière et fonctionnent à la fois sous Microsoft Windows, GNU/Linux, UNIX et MacOS X.

Des codes exploitant ces vulnérabilités sont disponibles sur l'Internet.

Adobe a publié un avis de sécurité précisant qu'un correctif sera mis à disposition le 12 mai 2009. Il concernera les systèmes d'exploitation Windows, MacOS et Unix.

5 Contournement provisoire

Dans l'attente d'un correctif approprié, il est recommandé de désactiver le support du JavaScript dans Adobe Reader et Adobe Acrobat en décochant l'option Activer Acrobat Javascript dans Edition -> Preferences -> Javascript ;

6 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

7 Documentation

Gestion détaillée du document

28 avril 2009
version initiale.
29 avril 2009
les vulnérabilités touchent également Acrobat et fonctionnent sur toute plateforme, ajout de la référence au bloc-notes d'Adobe.
07 mai 2009
ajout de la référence au bulletin Adobe APSA09-02 et aux CVE associés.
13 mai 2009
correctif disponible.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-28