Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2009-AVI-559

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 22 décembre 2009
No CERTA-2009-AVI-559

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilités dans Winamp


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2009-AVI-559

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2009-AVI-559
Titre Vulnérabilités dans Winamp
Date de la première version 22 décembre 2009
Date de la dernière version -
Source(s) Bulletin de version de Winamp du 21 décembre 2009
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

Winamp, versions antérieures à la version 5.571.

3 Résumé

Plusieurs vulnérabilités dans Winamp sont exploitables par un utilisateur malveillant pour exécuter du code arbitraire à distance.

4 Description

Plusieurs vulnérabilités sont présentes dans Winamp et permettent à un utilisateur malveillant d'exécuter du code arbitraire à distance en incitant un utilisateur du système vulnérable à ouvrir un fichier spécialement conçu :
  • un débordement d'entier survient dans le décodeur IN_MOD.DLL lors de l'analyse de certains fichiers de type Oktalyzer, Ultratracker ou Impulse Tracker ;
  • plusieurs débordements d'entier sont présents dans les modules png.w5s et jpeg.w5s et sont exploitables par le biais de fichiers JPEG ou PNG spécifiques contenus dans un fichier MP3.

5 Solution

Migrer en version 5.571.

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

22 décembre 2009
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23