Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2010-AVI-149

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 01 avril 2010
No CERTA-2010-AVI-149

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités dans Firefox


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2010-AVI-149

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2010-AVI-149
Titre Multiples vulnérabilités dans Firefox
Date de la première version 01 avril 2010
Date de la dernière version -
Source(s) Bulletin de sécurité de la fondation Mozilla 2010/mfsa2010-16 à 24 du 30 mars 2010
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Exécution de code arbitraire à distance ;
  • déni de service à distance ;
  • contournement de la politique de sécurité.

2 Systèmes affectés

Firefox, versions 3.6.x, 3.5.x, 3.0.x.

3 Résumé

De multiples vulnérabilités affectent Firefox dont les plus importantes permettent à un utilisateur malveillant d'exécuter du code arbitraire à distance sur le système vulnérable.

4 Description

Plusieurs vulnérabilités affectent Firefox :
  • dans certaines circonstances, le navigateur s'arrête de manière inopinée, permettant à un attaquant de provoquer un déni de service à distance ;
  • plusieurs défauts dans l'allocation de la mémoire et dans la gestion des pointeurs permettent à un utilisateur malveillant d'exécuter du code arbitraire à distance ;
  • la possibilité pour une applette de détourner des clics de souris permet à un utilisateur malveillant d'exécuter du code arbitraire à distance ;
  • un défaut dans l'extension Firebug permet à un utilisateur malveillant d'exécuter du code arbitraire à distance ;
  • un défaut dans le traitement du protocole SSL permet à un utilisateur distant de contourner la politique de sécurité ;
  • la présence d'un lien mailto: dans un objet image provoque le lancement du client de messagerie. L'impact est un désagrément ;
  • des vérifications omises pendant le traitement de documents XML peuvent conduire au chargement d'objets non permis par la politique de sécurité.

5 Solution

Les versions Firefox 3.6.2 et 3.5.9 remédient à toutes les vulnérabilités.

La version 3.0.19 remédie aux vulnérabités sauf les deux dernières. La branche 3.0 n'étant désormais plus maintenue, la migration vers les branches 3.5 ou 3.6 offre une solution de plus long terme.

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

01 avril 2010
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-08-17