Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2011-ALE-007

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 26 décembre 2011
No CERTA-2011-ALE-007-001

Affaire suivie par :

CERTA

BULLETIN D'ALERTE DU CERTA

Objet : Vulnérabilité dans ftpd et ProFTPD sur FreeBSD


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2011-ALE-007

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2011-ALE-007-001
Titre Vulnérabilité dans ftpd et ProFTPD sur FreeBSD
Date de la première version 02 décembre 2011
Date de la dernière version 26 décembre 2011
Source(s)  
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Exécution de code arbitraire à distance ;
  • élévation de privilèges.

2 Systèmes affectés

  • ftpd fourni avec FreeBSD versions 8.2 et inférieures ;
  • ftpd fourni avec FreeBSD versions 8.2 amd64 et inférieures ;
  • ProFTPD sur FreeBSD.

3 Résumé

Une vulnérabilité présente dans ftpd et ProFTPD sur FreeBSD permet à une personne malintentionnée distante d'exécuter du code arbitraire avec les privilèges administrateur (root).

4 Description

Une vulnérabilité est présente dans ftpd et ProFTPD sur FreeBSD. Elle permet à un utilisateur malintentionné distant d'exécuter du code arbitraire avec les privilèges administrateur (root). L'attaque est possible si :
  • l'attaquant est en mesure de se connecter au serveur FTP en utilisant un compte utilisateur valide qui sera dans un environnement cloisonné (chroot), ou en tant qu'utilisateur anonyme avec les droits en écriture dans son répertoire racine ;
  • le compte FTP utilisé possède les droits en écriture dans les répertoires lib et etc ou peut les créer s'ils n'existent pas.

L'attaque consiste à copier des fichiers, dont une bibliothèque malveillante dans le réperoire lib. La bibliothèque malveillante est ensuite chargée lorsqu'une commande FTP particulière est effectuée.

Une preuve de faisabilité est disponible sur Internet.

5 Contournement provisoire

Supprimer les droits en écriture sur les dossiers lib et etc permet d'empêcher l'attaquant de déposer les fichiers nécessaires à l'exploitation de la vulnérabilité.

6 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

7 Documentation

Gestion détaillée du document

02 décembre 2011
version initiale.
26 décembre 2011
ajout des correctifs FreeBSD.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-04-20