Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2011-AVI-101

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 22 mars 2011
No CERTA-2011-AVI-101-001

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités dans Ruby


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2011-AVI-101

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2011-AVI-101-001
Titre Multiples vulnérabilités dans Ruby
Date de la première version 22 février 2011
Date de la dernière version 22 mars 2011
Source(s) Notes de mise à jour Ruby du 18 février 2011
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Contournement de la politique de sécurité ;
  • atteinte à l'intégrité des données.

2 Systèmes affectés

Pour la vulnérabilité sur la méthode Exception#to_s :
  • Ruby versions 1.8.6 niveau de patch 420 et précédentes ;
  • Ruby versions 1.8.7 niveau de patch 330 et précédentes ;
  • Ruby versions de développement 1.8 (1.8.8dev).

Pour la vulnérabilité sur la méthode FileUtils.remove_entry_secure :

  • Ruby versions 1.8.6 niveau de patch 420 et précédentes ;
  • Ruby versions 1.8.7 niveau de patch 330 et précédentes ;
  • Ruby versions de développement 1.8 (1.8.8dev) ;
  • Ruby versions 1.9.1 niveau de patch 430 et précédentes ;
  • Ruby versions 1.9.2 niveau de patch 136 et précédentes ;
  • Ruby versions de développement 1.9 (1.9.3dev).

3 Résumé

Deux vulnérabilités dans Ruby ont été corrigées. La première permet de contourner la politique de sécurité et la seconde de porter atteinte à l'intégrité des données.

4 Description

La première vulnérabilité touche la méthode to_s de la classe Exception. Celle-ci permet à un attaquant de déjouer le mécanisme de sécurité permettant la séparation des données issues de sources extérieures au programme. La seconde vulnérabilité affecte la méthode remove_entry_secure de la classe FileUtils. Celle-ci cause une situation de compétition (race condition), qui permet à une personne malveillante d'utiliser des liens symboliques pour forcer la suppression de fichiers ou de répertoires sur le système.

5 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

22 février 2011
version initiale ;
22 mars 2011
ajout des références CVE.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-23