Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2011-AVI-211

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 13 avril 2011
No CERTA-2011-AVI-211

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans Microsoft .NET Framework


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2011-AVI-211

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2011-AVI-211
Titre Vulnérabilité dans Microsoft .NET Framework
Date de la première version 13 avril 2011
Date de la dernière version -
Source(s) Bulletin de sécurité Microsoft MS11-028 du 12 avril 2011
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows XP SP 3 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows XP Pro x64 SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Server 2003 SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Server 2003 Édition x64 SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Server 2003 SP2 pour systèmes Itanium ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Vista SP 1 et Windows Vista SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Vista Édition x64 SP 1 et Windows Vista Édition x64 SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Server 2008 pour systèmes 32 bits et Windows Server 2008 pour systèmes 32 bits SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Server 2008 pour systèmes x64 et Windows Server 2008 pour systèmes x64 SP 2 ;
  • Microsoft .NET Framework 2.0 SP 2 et Microsoft .NET Framework 3.5 SP 1 sur Windows Server 2008 pour systèmes Itanium et Windows Server 2008 pour systèmes Itanium SP 2 ;
  • Microsoft .NET Framework 3.5.1 sur Windows 7 pour systèmes 32 bits et Windows 7 pour systèmes 32 bits SP 1 ;
  • Microsoft .NET Framework 3.5.1 sur Windows 7 pour systèmes x64 et Windows 7 pour systèmes x64 SP 1 ;
  • Microsoft .NET Framework 3.5.1 sur Windows Server 2008 R2 pour systèmes x64 et Windows Server 2008 R2 pour systèmes x64 SP 1 ;
  • Microsoft .NET Framework 3.5.1 sur Windows Server 2008 R2 pour systèmes Itanium et Windows Server 2008 R2 pour systèmes Itanium SP 1;
  • Microsoft .NET Framework 4.0 sur Windows XP SP 3 ;
  • Microsoft .NET Framework 4.0 sur Windows XP Pro x64 SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2003 SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2003 Édition x64 SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2003 avec SP2 pour systèmes Itanium ;
  • Microsoft .NET Framework 4.0 sur Windows Vista SP 1 et Windows Vista SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Vista Édition x64 SP 1 et Windows Vista Édition x64 SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2008 pour systèmes 32 bits et Windows Server 2008 pour systèmes 32 bits SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2008 pour systèmes x64 et Windows Server 2008 pour systèmes x64 SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2008 pour systèmes Itanium et Windows Server 2008 pour systèmes Itanium SP 2 ;
  • Microsoft .NET Framework 4.0 sur Windows 7 pour systèmes 32 bits et Windows 7 pour systèmes 32 bits SP 1
  • Microsoft .NET Framework 4.0 sur Windows 7 pour systèmes x64 et Windows 7 pour systèmes x64 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2008 R2 pour systèmes x64 et Windows Server 2008 R2 pour systèmes x64 SP 1 ;
  • Microsoft .NET Framework 4.0 sur Windows Server 2008 R2 pour systèmes Itanium et Windows Server 2008 R2 pour systèmes Itanium SP 1.

3 Résumé

Une vulnérabilité dans Microsoft .NET Framework peut être utilisée par une personne malveillante pour exécuter du code arbitraire.

4 Description

Une vulnérabilité a été corrigée dans la façon dont Microsoft .NET Framework traite certains appels de fonction. Cette vulnérabilité, de type corruption de mémoire, peut être utilisée par une personne malveillante distante pour provoquer de l'exécution de code arbitraire. Elle peut être exploitée sur un système client en dirigeant un utilisateur vers une page spécialement conçue. Elle peut également être exploitée sur un serveur IIS, supportant les pages ASP.NET, si un attaquant parvient à y déposer une page ASP.NET spécialement conçue.

5 Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

6 Documentation

Gestion détaillée du document

13 avril 2011
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-08-17