Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2011-AVI-305

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 20 mai 2011
No CERTA-2011-AVI-305

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Multiples vulnérabilités dans Moodle


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2011-AVI-305

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2011-AVI-305
Titre Multiples vulnérabilités dans Moodle
Date de la première version 20 mai 2011
Date de la dernière version -
Source(s) Annonce des nouvelles versions de Moodle du 19 mai 2011
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Déni de service à distance ;
  • atteinte à la confidentialité des données ;
  • injection de code indirecte à distance.

2 Systèmes affectés

  • Moodle versions 2.0.x antérieures à 2.0.3 ;
  • Moodle versions 1.9.x antérieures à 1.9.12.

3 Résumé

De multiples vulnérabilités dans Moodle permettent, entre autres, de réaliser un déni de service ou une injection de code indirecte à distance.

4 Description

De multiples vulnérabilités ont été découvertes dans Moodle :

  • un enseignant peut voir les rapports de quizz de tous les étudiants, même ceux qui ne sont pas dans ses groupes (MSA-11-0013) ;
  • les adresses de messagerie des utilisateurs sont affichées dans la page de profil, lorsqu'elles ne devraient apparaître qu'aux membres du cours seulement (MSA-11-0014) ;
  • plusieurs injections de code indirectes sont possibles (MSA-11-0015) ;
  • un utilisateur légitime peut créer plusieurs enregistrements invalides dans la base de données, ce qui peut conduire à un déni de service (MSA-11-0016) ;
  • un utilisateur légitime peut remplir la table des commentaires dans la base de données avec des enregistrements invalides (MSA-11-0017).

5 Solution

Les versions 2.0.3 et 1.9.12 de Moodle corrigent ces vulnérabilités.

6 Documentation

Gestion détaillée du document

20 mai 2011
version initiale.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-28