Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2013-ALE-005

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2017 Archive

Année 2016 Archive

Année 2015 Archive

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 24 mai 2013
No CERTA-2013-ALE-005-002

Affaire suivie par :

CERTA

BULLETIN D'ALERTE DU CERTA

Objet : Vulnérabilité dans le noyau Linux


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2013-ALE-005

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2013-ALE-005-002
Titre Vulnérabilité dans le noyau Linux
Date de la première version 14 mai 2013
Date de la dernière version 24 mai 2013
Source(s) Correctif de sécurité du noyau Linux du 13 avril 2013
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque(s)

  • élévation de privilèges.

2 Systèmes affectés

  • Noyau Linux de la version 2.6.37 à la version 3.8.8 ;
  • Debian version stable (Wheezy) ;
  • CentOS version stable (6.4) avec un noyau 2.6.32 qui intègre la fonctionnalité ;
  • Toutes les autres distributions sont probablement vulnérables si elles utilisent un noyau concerné.

Les noyaux Linux versions supérieures à 3.8.8 et inférieures à 2.6.37 ne semblent pas être affectés, ainsi que les dernières versions stables supportées par le noyau Linux :

  • Noyau Linux version 3.4.45
  • Noyau Linux version 3.2.45
  • Noyau Linux version 3.0.78

3 Résumé

Une vulnérabilité a été corrigée dans le noyau Linux. Elle permet à un attaquant de provoquer une élévation de privilèges. Un code d'exploitation est disponible publiquement et activement utilisé.

4 Contournement provisoire

En attendant que votre distribution intègre le correctif, il est possible de contourner le code d'exploitation en utilisant un noyau durci tel que grsecurity ou les fonctionnalités processeurs :

  • Supervisor Mode Access Prevention ;
  • Supervisor Mode Execution Protection.
Il est aussi possible de :
  • recompiler son noyau avec le correctif du noyau Linux ;
  • recompiler son noyau en désactivant la fonctionnalité CONFIG_PERF_EVENTS ;
  • d'utiliser un noyau vanilla stable corrigé.

5 Solution

Installer les derniers correctifs de votre distribution Linux :

  • Debian : DSA-2669-1
  • Ubuntu LTS : USN-1825-1, USN-1828-1
  • Red Hat : RHSA-2013-0830, RHSA-2013-0832, RHSA-2013-0829, RHSA-2013-0840, RHSA-2013-0841
  • SUSE Linux Enterprise : SUSE-SU-2013:0819-1

Mandriva n'a pas encore corrigé la vulnérabilité.

6 Documentation

Gestion détaillée du document

14 mai 2013
version initiale.
22 mai 2013
ajout correctifs éditeurs.
24 mai 2013
ajout correctif SUSE.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2017-03-27