Risques

  • Déni de service
  • Exécution de code arbitraire à distance

Systèmes affectés

    Ethereal versions 0.9.0 à 0.10.7 incluse.

    Description

    Ethereal est un renifleur réseau. Il permet l'analyse de données depuis le réseau ou à partir d'un fichier. Quatre vulnérabilités ont été découvertes dans Ethereal :

    • une première vulnérabilité lors de l'analyse de certains paquets DICOM permet à un utilisateur mal intentionné de créer un déni de service. Cette vulnérabilité affecte les versions 0.10.4 à 0.10.7 d'Ethereal ;
    • une vulnérabilité est dûe à une mauvaise manipulation du champ timestamp contenu dans l'entête des paquets RTP (Real-Time Transfert Protocol). L'exploitation de cette vulnérabilité par un individu mal intentionné permet d'arrêter le programme ou de créer un fichier temporaire pouvant occuper l'ensemble de l'espace disque disponible. Cette vulnérabilité affecte les versions 0.10.1 à 0.10.7 incluse ;
    • une vulnérabilité présente dans la manipulation de paquets HTTP, peut sous certaines conditions, causer l'arrêter du programme. Cette vulnérabilité affecte les versions 0.10.1 à 0.10.7 d'Ethereal ;
    • une vulnérabilité dans la gestion de certains paquets SMB (Server Message Block) permet à un utilisateur mal intentionné de créer un déni de service par l'envoi de paquets SMB malicieusement construits afin de consommer toutes les ressources CPU. Cette vulnérabilité affecte les versions 0.9.0 à 0.10.7 d'Ethereal.

    Solution

    Mettre à jour Ethereal avec la version 0.10.8 corrigeant ces vulnérabilités (cf. Documentation).

    Documentation