Risque(s)

  • Exécution de code arbitraire

Systèmes affectés

  • OpenSSL versions 1.0.2 antérieures à 1.0.2zf
  • OpenSSL versions 1.1.1 antérieures à 1.1.1p
  • OpenSSL versions 3.0.x antérieures à to 3.0.4

Résumé

Une vulnérabilité a été découverte dans OpenSSL c_rehash. Elle permet à un attaquant de provoquer une exécution de code arbitraire.

Solution

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

Documentation